You must be logged in to post messages.
Please login or register

Technical Help and Bug Reporting

Hop to:    
Welcome! You are not logged in. Please Login or Register.8 replies
Total War Heaven » Forums » Technical Help and Bug Reporting » 3D sound not initializing!
Bottom
Topic Subject:3D sound not initializing!
Finster150
Legionary
posted 03 July 2013 03:52 EDT (US)         
Hello, and thank you in advance for the help!
I have been browsing the internet for far too long trying to find a solution to my particular problem, and so far one has not appeared to me. If nothing turns up (which I highly doubt) I'll fall back on pre-ordering Rome II: Total War :P I will describe how the issue began.

I installed the SPQR 8.0 mod, but not realising it was not made for total noobs, I was utterly defeated with the first battle with Hannibal. I lack confidence anyway, so I promptly decided the mod was not for me. I therefore decided to completely reinstall Rome: Total War to remove this mod. After a cursory glance around the Rome: Total War folder in Program Files(x86) and the menu that opens up when the CD is inserted, I found no uninstall option. Therefore, I proceeded to delete the Rome: Total War folder. This is where the issues began. I put my CD back in and tried to install it again. However, only the "Play Rome: Total War" and "Play Barbarian Invasion" buttons were highlighted, not the install button. I tried the manual uninstall option (Deleting the registry files) following the advice of some forum posters. I noticed loads of the files were already gone, and this did not solve my problem once I had completed it. I looked around the web, found no answers, and decided to system restore back to two days ago. I did this successfully, and went to run Barbarian Invasion, however the "3D sound not initialised" error came up. I tried it again, then tried vanilla Rome: Total War. The same thing happened. Once again I searched through hundreds of forum posts and not a single one fixed my problem.
My 'miles' folder is missing from my Program Files(x86)/The Creative Assembly/Rome: Total War folder. The mss32.dll file is there. There is no Rome Total War.ini file. I am using Rome: Total War Gold Edition (RTW Vanilla and Barbarian Invasion) I use the CD version, not the Steam version.
All of my sound drivers are fully updated (according to Windows.)
I am running a Windows 7 64-bit Acer Aspire Laptop. This is read off of the sticker by my numpad:
- AMD Dual-Core Processor A4-3305M
with Turbo CORE Technology up to 2.50 GHz
- AMD Radeon HD 6480G with 512 MB Graphics System Memory
- 15.6" HD LED LCD
- DVD-Super Multi DL Drive
- 4 GB DDR3 Memory Installed
- Ace Nplify802 11b/g/n
- 750 GB HDD
- 6 cell Li-ion battery
Most of this means nothing to me, and I am a complete noob when it comes to technology. Please, if your solution involves going into Control Panel's Hardware and Sound folder, say "Go to Start => Control Panel =>Hardware and Sound." While I obviously know where that is, I do not know a lot of what most people consider basic knowledge. Please leave a full pathway to finding things if possible.
This is as much as I can think of right now that could be useful. If you need any more information (like my dxdiag) tell me and I'll try my best to get it to you ASAP Once again, thank you in advance.
AuthorReplies:
Terikel Grayhair
Imperator
(id: Terikel706)
posted 03 July 2013 06:25 EDT (US)     1 / 8       
Before trying to re-install, ensure you deleted all of the RTW and BI entries from the registry.

Make sure you search (ctrl+f) for all forms of RTW, Rome, and Total War. Do NOT delete anything you are not sure is part of the game! The registry puts different parts of the installation in different folders, thus a search through the entire Registry is needed to weed out all the bits (especially since your uninhstall was not present).

Once you are sure you have purged it all, then try the re-install.

Good luck!

And welcome to our forums!

|||||||||||||||| A transplanted Viking, born a millennium too late. |||||||||||||||||
|||||||||||||||| Too many Awards to list in Signature, sorry lords...|||||||||||||||||
|||||||||||||||| Listed on my page for your convenience and envy.|||||||||||||||||
Somewhere over the EXCO Rainbow
Master Skald, Order of the Silver Quill, Guild of the Skalds
Champion of the Sepia Joust- Joust I, II, IV, VI, VII, VIII

[This message has been edited by Terikel Grayhair (edited 07-03-2013 @ 06:29 AM).]

Finster150
Legionary
posted 04 July 2013 01:23 EDT (US)     2 / 8       
Thank you for the quick response Terikiel!
I followed the instructions for deleting all things from the registry from this website: http://shoguntotalwar.yuku.com/topic/11047/MANUAL-UNINSTALL-PROCEDURE-for-RTWampBI#.UdUSTPk3AhR.
I noted a lot of the things that needed deleting weren't there anyway:
{4089999C-6CB7-4F9D-A2F6-DB158DBF91FB}
{B6BB246A-D1AC-2414-D84D-13C8F3D38C43}
InstallShield_{4089999C-6CB7-4F9D-A2F6-DB158DBF91FB}
InstallShield_{B6BB246A-D1AC-2414-D84D-13C8F3D38C43}
And generally any variations of this were not found anywhere during the purging.
I do not understand step 10, and what it means by 'codecs.'
I could not find RomeTW.ini anywhere in the C Drive using Windows Explorer (knowing me, I probably used it wrong) and there was no 'Installshield Installation' folder in Program Files (Step 4-4 to 9)even after having my computer reveal all normally hidden files etc. etc. After rebooting my computer and putting my disc back in, it still does not have 'Install' highlighted, and Play 'RTW' and 'BI' are still highlighted.
Using Ctrl+F to find files in the registry, I deleted all relevant files I found under 'RTW' 'Rome' 'Rome[:] Total War' and 'Total War.' Clearly however, RTW is still hidden somewhere. :'(
Once again, thank you for the suggestion

[This message has been edited by Finster150 (edited 07-04-2013 @ 01:25 AM).]

Terikel Grayhair
Imperator
(id: Terikel706)
posted 04 July 2013 02:45 EDT (US)     3 / 8       
There must be something you missed- agreed.

I read through the link- a codecs is a means of registering and indexing files and programs. The guy who wrote that list went into far more detail thaqn necessary- but then again, he was writing for advanced users, not tyroes like us. I would not worry about that too much.

The autorun thing does not have Install, you say. Have you tried going directly to the disk and using setup from there? It might fill in the gaps.

You can also try installing a second copy of RTW and simply using that.

|||||||||||||||| A transplanted Viking, born a millennium too late. |||||||||||||||||
|||||||||||||||| Too many Awards to list in Signature, sorry lords...|||||||||||||||||
|||||||||||||||| Listed on my page for your convenience and envy.|||||||||||||||||
Somewhere over the EXCO Rainbow
Master Skald, Order of the Silver Quill, Guild of the Skalds
Champion of the Sepia Joust- Joust I, II, IV, VI, VII, VIII
Finster150
Legionary
posted 04 July 2013 02:57 EDT (US)     4 / 8       
Hi,
Apologies, but what do you mean by 'going directly to the disk?' If you mean ejecting then re-inserting the disk, that's what I have done, but I think that isn't what you mean ;D
I looked at installing the second copy of RTW, but that required having the files. They are in the Recycle Bin, but I do not have the miles folder, so if it's important, that won't be a solution either :/
Thanks for being patient with me
EDIT:
I've just opened the files on the CD by opening the folder rather than running the program, and it's given me three options:
1: Modify
"Select new program features to add or select currently installed features to remove.
2: Repair
"Reinstall all program features installed by the previous setup."
3. Remove
"Remove all installed features."
Which is the wisest course of action to take?

[This message has been edited by Finster150 (edited 07-04-2013 @ 03:13 AM).]

Terikel Grayhair
Imperator
(id: Terikel706)
posted 04 July 2013 04:44 EDT (US)     5 / 8       
That is what I meant.

Try the Repair option first- that is most like what you are trying to do- to get your game working.

If that fails to correct the problem, try Remove and then re-install.

The worst thing that can happen is that you have to remove everything+registry and start all over. Best case scenario- it installs the missing pieces and your game works.

Not exactly win-win, but not win-lose either. More like win- no win.

|||||||||||||||| A transplanted Viking, born a millennium too late. |||||||||||||||||
|||||||||||||||| Too many Awards to list in Signature, sorry lords...|||||||||||||||||
|||||||||||||||| Listed on my page for your convenience and envy.|||||||||||||||||
Somewhere over the EXCO Rainbow
Master Skald, Order of the Silver Quill, Guild of the Skalds
Champion of the Sepia Joust- Joust I, II, IV, VI, VII, VIII

[This message has been edited by Terikel Grayhair (edited 07-04-2013 @ 04:48 AM).]

Finster150
Legionary
posted 04 July 2013 23:54 EDT (US)     6 / 8       
Yay it works! Thank you so much for your help! Very much appreciated Have a pat on the back, it's on the house xD But seriously, thank you for the help you've provided.
Terikel Grayhair
Imperator
(id: Terikel706)
posted 05 July 2013 02:49 EDT (US)     7 / 8       
Happy to be of service.

Enjoy your game.

|||||||||||||||| A transplanted Viking, born a millennium too late. |||||||||||||||||
|||||||||||||||| Too many Awards to list in Signature, sorry lords...|||||||||||||||||
|||||||||||||||| Listed on my page for your convenience and envy.|||||||||||||||||
Somewhere over the EXCO Rainbow
Master Skald, Order of the Silver Quill, Guild of the Skalds
Champion of the Sepia Joust- Joust I, II, IV, VI, VII, VIII
Terikel Grayhair
Imperator
(id: Terikel706)
posted 09 July 2013 05:34 EDT (US)     8 / 8       
Ironically, I had this same problem a day after solving yours.

I followed my own advice and got precisely nowhere.

So I did a full re-install- again, nix.

So I ran a anti-virus check and found one. I removed it, made sure my mss32.dll file was copied into my Miles folder, then did a system restore on top of that.

Then everything worked.

Moral of the story: sometimes a repair or re-install is not enough. Check for viruses, too- Sometimes a virus will nest in a place where it disurpts good gaming experience. Remove it, fix everything, then all works and I can happily slaughter Roman pixels again.

|||||||||||||||| A transplanted Viking, born a millennium too late. |||||||||||||||||
|||||||||||||||| Too many Awards to list in Signature, sorry lords...|||||||||||||||||
|||||||||||||||| Listed on my page for your convenience and envy.|||||||||||||||||
Somewhere over the EXCO Rainbow
Master Skald, Order of the Silver Quill, Guild of the Skalds
Champion of the Sepia Joust- Joust I, II, IV, VI, VII, VIII
You must be logged in to post messages.
Please login or register

Hop to:    

Total War Heaven | HeavenGames