You must be logged in to post messages.
Please login or register

Technical Help and Bug Reporting

Hop to:    
Welcome! You are not logged in. Please Login or Register.1 reply
Total War Heaven » Forums » Technical Help and Bug Reporting » Patch 1.3
Bottom
Topic Subject:Patch 1.3
renobe
Legionary
posted 15 June 2019 13:41 EDT (US)         
Ever since I installed patch 1.3 on a XP machine in 2011 the game has been acting strange. I bought the game in the early 2000's at Walmart in installed patch 1.1 and 1.2. I wonder if patch 1.3 was created for a os after XP. I installed the patch 1.3 & 1.5 much later because I had a dial up for my ISP. A week ago I reinstalled the game in patches to no avail.
AuthorReplies:
Terikel Grayhair
Imperator
(id: Terikel706)
posted 18 June 2019 12:42 EDT (US)     1 / 1       
The latest patch is 1.6, I believe. It comes with BI.

The patch order is 1.2 then 1.3 then 1.4 (old BI) then 1.5, then 1.6

Installing the old BI will roll your patched 1.5 RTW back, installing the new (relatively new) one will upgrade 1.5 to 1.6.

The patches fixed a lot of bugs. That might be your problem, those bugs that are not fixed.

|||||||||||||||| A transplanted Viking, born a millennium too late. |||||||||||||||||
|||||||||||||||| Too many Awards to list in Signature, sorry lords...|||||||||||||||||
|||||||||||||||| Listed on my page for your convenience and envy.|||||||||||||||||
Somewhere over the EXCO Rainbow
Master Skald, Order of the Silver Quill, Guild of the Skalds
Champion of the Sepia Joust- Joust I, II, IV, VI, VII, VIII
You must be logged in to post messages.
Please login or register

Hop to:    

Total War Heaven | HeavenGames