You must be logged in to post messages.
Please login or register

Rome: Total War Discussion
Moderated by Terikel Grayhair, General Sajaru, Awesome Eagle

Hop to:    
Welcome! You are not logged in. Please Login or Register.1 reply
Total War Heaven » Forums » Rome: Total War Discussion » Playing multiplayer
Bottom
Topic Subject:Playing multiplayer
Enkidu of Uruk
Legionary
(id: thekid951)
posted 04 March 2007 11:35 EDT (US)         
Hi

I've been playing multiplayer for a while, and today I wanted to play again but found all the games to be 'non compatible'. I asked on the chat why and they said I needed version 1.5. But I have 1.5, I've been playing before. So I went to options and checked the top right corner and , suprisingly, it said " v 1.3"

So the question is: how did it come my 1.5 dissappeared?

thanks.

Also, I forgot where to download 1.5, so if someone could perhaps post the link...


[This message has been edited by TheKid951 (edited 03-04-2007 @ 11:38 AM).]

AuthorReplies:
Severous
Legionary
posted 04 March 2007 16:44 EDT (US)     1 / 1       
I have two RTW ICONs on my desktop.

One starts RTW V1.5 and the other RTW BI V1.6

Maybe the link/shortcut/icon you use to start your version Kid has changed?

You must be logged in to post messages.
Please login or register

Hop to:    

Total War Heaven | HeavenGames