You must be logged in to post messages.
Please login or register

Technical Help and Bug Reporting

Hop to:    
Welcome! You are not logged in. Please Login or Register.36 replies, Sticky
Total War Heaven » Forums » Technical Help and Bug Reporting » Patch 1.5/1.6 Install Help + Experiences + Bugs
Bottom
Topic Subject:Patch 1.5/1.6 Install Help + Experiences + Bugs
« Previous Page  1 2  Next Page »
Wartrain
Legionary
posted 09 December 2005 14:13 EDT (US)         
Patch 1.5/1.6 Install Help + Your Experiences + Bugs/Issues


PURPOSE
1. Locate download links.
2. Estimate patching time requirements.
3. Your patch experience: post your successful (or unsuccessful) install experiences; it might help others (be sure to state your basic system specs; see example).
4. Summary of Reported patch issues, bugs, comments.

1. USEFUL LINKS:
DOWNLOAD Patch 1.3, 1.5, 1.6
README for Patch 1.5/1.6
export_descr_buildings.txt - (Only for Patch 1.5 & 1.6!) this file must be placed in the RTW Data directory (e.g., c:\Program Files\Rome - Total War\data).
Here is Patch 1.2
Manually uninstall RTW
Desktop Install RTW 1.0
Install multiple versions of RTW in one drive.

2. TASK ACCOMPLISHMENT APPROXIMATIONS:

TASK                       :  TIME (Typical)
========================== ==============================================
Auto-uninstall RTW : about 3 minutes.
Manually uninstall RTW : over 1 hour.
CD-based RTW 1.0 install : about 20 minutes.
Desktop Install RTW 1.0 : about 10 minutes (after 3 CD contents copied).
Install Patch 1.3 : less than 30 seconds.
Install Patch 1.5 : less than 5 seconds.
Install Epona Roman Fix : about 30 seconds (locate DATA directory).

3. YOUR PATCH EXPERIENCES:

Make a post in this thread describing how your patch went. Include basic system info, like CPU, RAM, Graphic Card (GPU), Operating System (OS)+Service Pack (SP), what RTW(s) versions you installed, and comments.

Example of report format:

CPU: AMD Athlon XP 2600+
GRAPHIC CARD: nVidia MX400 integrated, 128MB RAM
OS: Windows XP, SP2, all critical updates applied.
INSTALLED RTW PATCHES+MODS: Installed 1.3 and 1.5 + All Factions Mod
COMMENTS: Patched successfully to 1.3, then patched successfully to 1.5. Tested good for all campaigns. Successfully loaded and played 1.2 saves, but 1.3 saves were not tested. Scipii now behave normally in Sicily.......


4. SUMMARY OF REPORTED ISSUES, BUGS, COMMENTS:

PATCH 1.5 ISSUES:
* - If you install Patch 1.5 over 1.2, Patch 1.5 seems to partly uninstall some stuff and then make a mess. I was not able to do a successful auto uninstall as a result, and had to do the manual uninstall procedure.
* - It seems that Naked Fanatics are still recruitable as Gaul.


PATCH 1.6 ISSUES:
? - It seems that Naked Fanatics are still recruitable as Gaul.
? - Have only tested on Goths and Franks, if you are in the Red with your cash and use the horde button then sack the city you just left you get 2Billion Denarii but only if your in the red. [**could this be a dev cheat code? Is it repeatable?]
** All factions, not only Romans, can upgrade to an Awesome Temple or Pantheon temple_of_horse (Epona).

KEY:
? - Can more people check this out & post?
* - Pretty solid evidence.
** - Confirmed by more than one person.

Note: README for CA Patch 1.5 and Patch 1.6 moved here (post#5) to reduce clutter.

EDIT: Added link for Patch 1.2.

EDIT: (30Dec2005) A (relatively minor) bug affecting only Patches 1.5 & 1.6 is now officially corrected in an "ADDITIONAL ROME CAMPAIGN FIX FOR PATCHES 1.5/1.6". CA intended for only Romans to upgrade a temple_of_horse past level 3, and says "Only Romans are now able to build an Awesome Temple or a Pantheon of Epona". In an unprecedented move for RTW, they provide a single-file fix:export_descr_buildings.txt - this file must be placed in the Rome data directory. Example path: c:\Program Files\Rome - Total War\data.

EDIT: (01Jan2006) Add:
Some people are having troubles with different versions of RTW/BI, and replaying/continuing savegames, like here. Based on known or published information, here is a summary matrix. If anyone has experiences other than this, post and explain so we can investigate/update/correct.


Matrix of RTW Campaign Savegame Compatibility
(revision 1.0)

1.0 1.1 1.2 1.3 1.4 1.5 1.6

1.0 YES YES YES NO NO YES YES

1.1 YES YES YES NO NO YES YES

1.2 YES YES YES NO NO YES YES

1.3 NO NO NO YES YES YES YES

1.4 NO NO NO YES YES YES YES

1.5 NO NO NO NO NO YES YES

1.6 NO NO NO NO NO YES YES

Notes:
1. The savegame is in the vertical column, on the left .
2. The version you want to play your savegame in is read across.
3. The way to read it is to ask, "Can my savegame saved in patch Y load/play with patch X?".

For instance:
- "Can my Patch 1.2 savegame be loaded & played in a Patch 1.3 version of RTW?" (No, it cannot)
- "I saved a game with original RTW (1.0); can it be played in a Patch 1.5 version of RTW?" (Yes, it can)
- "I saved RTW campaign game with BI (1.6); can it be played in a Patch 1.2 version of RTW?" (No, it cannot)

[This message has been edited by Wartrain (edited 01-01-2006 @ 07:42 AM).]

AuthorReplies:
Admiral Sushi
Legionary
posted 03 April 2008 20:37 EDT (US)     26 / 36       
I ended up fixing it; I think it was getting confused because I had several copies of "RomeTW.exe" in the same overall folder but in different subfolders. However, if I'm ever to play R:TW again, I'll have to reinstall it.

FA:TW installed fine, and started up fine, however, unpon attempting to start a campaign, it came up with: Generic Error cannot find data/world/something/temple_of_artemis.tga
I don't think you guys will be able to help me with that; I'll probably have to go to the FA:TW site and sign up and everything.

EDIT: Thank you for your help! (Sorry I didn't say so before)

Scientia potestas est.
"Hello, I_Jedi. We haven't met before, but I just wanted to say, I don't like you. Have a nice day." -- Viceroy Billy

[This message has been edited by Admiral Sushi (edited 04-06-2008 @ 08:50 PM).]

Shocked
Legionary
posted 26 June 2008 00:12 EDT (US)     27 / 36       
Ok so just let me qucikly get this right, So..

I haven't tried or attempted any patches and I bought the game last year.

I need to do the new patches to play online..

So I just do patch 1.3 and then 1.5??

Or do I also need to download patch 1.6?
SubRosa
Legionary
posted 26 June 2008 12:02 EDT (US)     28 / 36       
It depends on what you have. If you have RTW at 1.0 - 1.2, then patch to 1.3 then 1.5.

If you have Barbarian Invasion at 1.4 (which also means you will have RTW at 1.3) then just use the Barbarian Invasion 1.6 patch. It will automatically update RTW to 1.5 as well.

You can find out the version number you currently have by starting each, going to Options, and it will displayed in the upper right corner.

btw. welcome to TWH! :0

[This message has been edited by SubRosa (edited 06-26-2008 @ 12:03 PM).]

Shocked
Legionary
posted 26 June 2008 22:19 EDT (US)     29 / 36       
Thanks and, I just checked my game ver.
for RTW and it is 1.3 so I will update it to ver 1.5 now and then start playing online.

thanks for ya help.

Edit: I updated it, and put in the correct cd key with the '-'s between the numbers and letters and it still comes up with a message saying "Invalid cd key"

I AM SO ANNOYED... it's not modded in any way and it was bought legally from EB games.

[This message has been edited by Shocked (edited 06-26-2008 @ 10:48 PM).]

SubRosa
Legionary
posted 26 June 2008 23:08 EDT (US)     30 / 36       
This is actually a common problem with multiplayer. I had it myself too when I first tried entering my cd-key. Usually it is because you mistyped it. Make sure you don't mistake "0" for "o" or "O". When it is "0", there should be a diagonal stripe inside the oval.

[This message has been edited by SubRosa (edited 06-26-2008 @ 11:08 PM).]

Shocked
Legionary
posted 26 June 2008 23:46 EDT (US)     31 / 36       
Nope, it definitely isn't that problem..

I tried the thing with 0 and O and it didn't work either time.

There are no mistakes, I don't know what else could be wrong with my CD key..

Edit: I am pissed off...............

I have tried for hours today trying to make it work but all it comes up with is "Login Failed - Invalid CD key"

>

[This message has been edited by Shocked (edited 06-27-2008 @ 06:48 AM).]

Chechen
Legionary
posted 18 July 2008 19:53 EDT (US)     32 / 36       
Hi, i have a problem with installing 1.3 when im finished installing it says thats its completed but when i try to instal 1.5 it says that it needs 1.3....
Please help!
ed401
Legionary
posted 15 August 2008 10:28 EDT (US)     33 / 36       
HELP!!!
i have the same problem as spadesneedhelp did. has anyone figured out how to fix this as i am desperate to play alexander
SubRosa
Legionary
posted 15 August 2008 17:14 EDT (US)     34 / 36       
Try a complete manual uninstall, then reinstall There is a guide here. Be sure to follow every step, especially cleaning out the registry entries.
Nez Perce
Legionary
posted 09 August 2010 19:44 EDT (US)     35 / 36       
I patched 1.3 first & then 1.5 next
Then I tried to get on multi to play with some one on line & I get = logan failed-mandatory update required from www.totalwar.com
what update am I to look for? so I can get on multi.
sha50
Legionary
posted 10 October 2011 14:56 EDT (US)     36 / 36       
hi
when i want to patch my rome totalwar from 1.3 to 1.5 and 1.6 installation says (this installation program will now terminate.)how can i fix it? whats the problem?
« Previous Page  1 2  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Total War Heaven | HeavenGames