You must be logged in to post messages.
Please login or register

Technical Help and Bug Reporting

Hop to:    
Welcome! You are not logged in. Please Login or Register.4 replies
Total War Heaven » Forums » Technical Help and Bug Reporting » RTW won't play
Bottom
Topic Subject:RTW won't play
Kawada Shogo
Legionary
posted 28 January 2016 15:17 EDT (US)         
Firstly, sorry that this post will be almost a repeat of the previous two threads; I would have just commented on one of those, but they're already archived even though they're only a few months old. I think this site should change its policy on that, especially considering how inactive these forums are now.

Anyway, I recently got a new laptop and it's Windows 10 (my old computer that I usually play RTW on is Windows 7). Today I tried installing/playing RTW, but it won't work. It installed just fine, but when I click on the icon and try to start the game it just asks for permission to open the program and then it doesn't do anything.

I did a bit of Googling and it seems that other people have the same or similar problems. People recommended some solution involving Steam, but mine isn't a Steam game; it's the disc from the Total War: Eras collection. I want nothing to do with Steam, so anything involving that isn't an option for me. I just want to know, has anyone figured out how to solve this problem with the disc version?

I can still use RTW on my old computer, but although it plays ok, it doesn't play very well on it. I have to save the game frequently and quit/restart the game every hour or so to prevent it from crashing, and I can't have the game's graphics settings too high because my old computer can't handle it very well. I was looking forward to playing RTW on a computer that could handle it better. Because my new computer can play Medieval II (which was practically paralyzed when I tried it on my old one, almost totally unusable) without too much trouble *, I assume it will be able to play Rome Total War at its best. RTW is my favorite game, bar none, and i'd really like to be able to play it the way it was meant to be played. Besides which, that old computer has other unrelated problems (for instance an annoying problem with the sound system that I can't seem to get fixed) that cause me to prefer to be able to play my games on the new computer if possible. So, any help in figuring out how to make that happen would be appreciated.

* As a side note, regarding Medieval II, I was able to install disc 1 and play the main game, but it can't seem to install disc 2, the Kingdoms expansion pack (Teutonic, Crusades, Britannia and Americas), which I was really looking forward to. Does anyone know what the issue is with that?
AuthorReplies:
General Sajaru
Tribunus Laticlavius
posted 28 January 2016 23:34 EDT (US)     1 / 4       
I have not tried to install RTW from a disc on to my Windows 10 machine, but I'll give it a shot over the weekend and see if I can't get it to work.

"Freedom is never more than one generation away from extinction." - Ronald Reagan
"Judge them not by the color of their skin, but by the content of their character." - Martin Luther King, Jr.
"Pick up a rifle and you change instantly from a subject to a citizen." - Jeff Cooper
"I like my enemies like James Bond likes his martinis- shaken, not stirred."
My first book, The King's Own
MrMew
Huskarl
posted 30 January 2016 23:45 EDT (US)     2 / 4       
I've noticed with playing games on Windows 10 that you need to Run As administrator. This happened to me with AC2 and ACB. I haven't tried installing and running RTW on windows 10, but I'd assume running as admin should solve your issue.

Time of Tea
Still in the Dark Age
Don't be a melodramatic clown. ~Mr Wednesday
General Sajaru
Tribunus Laticlavius
posted 01 February 2016 19:29 EDT (US)     3 / 4       
So, I just installed RTW on my Windows 10 machine, enabled administrator privileges, and attempted to run it, at which point I remembered that I had issues with my Steam version of RTW as well. Apparently, Windows 10 and the anti-aliasing of RTW don't play well together, so you need to turn anti-aliasing off in order to make it work.

Apparently, since you need to have started the game and started a campaign in order to create the preferences folder/file in the first place, you might think you're pretty much screwed; however, since you have it on another computer, you can actually make this work. Find your preferences folder on your old computer; for Windows 7, it's in C:\Users\"Your Name"\AppData\Local\VirtualStore\Program Files (x86)\The Creative Assembly\Rome - Total War. Copy the whole folder onto a flash drive or similar, then move it to your new computer and stick it in the same place on your new computer. Now, open the preferences.txt file and find the line that says "AA_QUALITY" and change what comes after the colon to "AA_OFF". Then you should be able to launch your game. I had some issues with trying to do this because I have a dual drive setup on my Windows 10 machine, so please let us know how you fare.

"Freedom is never more than one generation away from extinction." - Ronald Reagan
"Judge them not by the color of their skin, but by the content of their character." - Martin Luther King, Jr.
"Pick up a rifle and you change instantly from a subject to a citizen." - Jeff Cooper
"I like my enemies like James Bond likes his martinis- shaken, not stirred."
My first book, The King's Own
Weaves
Legionary
posted 07 March 2016 21:59 EDT (US)     4 / 4       
If RTW uses safedisc, windows disabled in in a patch in Sept 2015. See my other thread.
You must be logged in to post messages.
Please login or register

Hop to:    

Total War Heaven | HeavenGames