You must be logged in to post messages.
Please login or register

Mongolphobia Mod

Hop to:    
Welcome! You are not logged in. Please Login or Register.46 replies, Sticky
Total War Heaven » Forums » Mongolphobia Mod » Report All the Technical Problems and Bugs Here.
Bottom
Topic Subject:Report All the Technical Problems and Bugs Here.
el_bandito
Legionary
posted 07 September 2008 22:00 EDT (US)         
So I will know them immediately.

At least a couple of people initially had problems installing the Mod but turned out they switched folders whole sale instead of simply dumping the contents as I instructed. Otherwise, not problems so far. It is a relatively simple Mod.

Michael Jackson
AuthorReplies:
EnemyofJupitor
HG Alumnus Superbus
posted 08 September 2008 10:41 EDT (US)     1 / 46       
Stuck

Just a note, make sure you have the latest version of the Grand Units Addon mod- I still had the version it first came out in

And I shall go Softly into the Night Taking my Dreams As will You
EnemyofJupitor
HG Alumnus Superbus
posted 24 September 2008 14:53 EDT (US)     2 / 46       
Seems there is a few things wrong with the descr_strat in my version- the Pope and a couple of other guys (rebels) are apparently on 'invalid tiles'. Regardless, I seem to get a crash end of turn one, regardless of what I do. Hm?

And I shall go Softly into the Night Taking my Dreams As will You
el_bandito
Legionary
posted 24 September 2008 21:39 EDT (US)     3 / 46       
Ok, have you moved or changed anything in the descr_strat file after you installed it? I never had that problem on my game but I kinda suspect there is a file conflict between the old and the new version.

Maybe you should re-replace the descr-strat file again from the v2 you got.

Does the problem happen with every faction?

Does the problem persist even when you start a new campaign?

I'm uploading v2.1 today. Try the descr_strat file of that please if it is still bugged. If nothing else works please report to me, this might be serious.

PS: What do you mean by Invalid Tiles? Like on the water?

Michael Jackson

[This message has been edited by el_bandito (edited 09-24-2008 @ 09:41 PM).]

SubRosa
Legionary
posted 24 September 2008 22:07 EDT (US)     4 / 46       
It is not surprising to get an invalid tile message when placing a settlement on a coastline. Another thing that would cause it is placing it in terrain that is impassable, like mountains. Typically when you see this the game will start the campaign and seem to play fine, then when you exit the game you receive an error message that the such and such settlement is on an invalid tile and will be ignored.
EnemyofJupitor
HG Alumnus Superbus
posted 25 September 2008 15:19 EDT (US)     5 / 46       
The pope's still on a mountain, but it works now.

It may well be to do with the BBB mod I had a go at. I must work out a way to combine the two

And I shall go Softly into the Night Taking my Dreams As will You
el_bandito
Legionary
posted 25 September 2008 21:47 EDT (US)     6 / 46       
Fear not EoJ. I realised my mistake. The Pope and 2 rebel armies were indeed on an impassable terrain. I fixed it(relocated em) and just re uploaded it in 2.1. Please download it again and switch its descr_strat file with yours. Thanks for the notification.

Michael Jackson
dustinmichaels
Legionary
posted 08 November 2008 01:34 EDT (US)     7 / 46       
Hi. I got the mod and I downloaded it, but I can't dump the one folder into the proper space. The unit can't be dumped because for me, they don't exist in the retrofit folder. I then dumped then in the Customs Campaign folder, because that one had the unit folders. I don't know which type of game I am supposed to start the game with. Am I supposed to run the normal, retrofit, or custom version? Please Reply-Thank you!
EnemyofJupitor
HG Alumnus Superbus
posted 08 November 2008 06:04 EDT (US)     8 / 46       
Hey, Dustin.

If you go to the M2TW base folder (the one with the 'Data', 'saves', etc), you should find a folder called 'mods'. Hit that, then the retrofit folder, then it's data file. You can now find the proper places to dump your files

And I shall go Softly into the Night Taking my Dreams As will You
dustinmichaels
Legionary
posted 09 November 2008 02:40 EDT (US)     9 / 46       
Oh ok thanks. So I dumped the stuff into the folders, but then I ran the retrofit mod and it was just the normal mod, and not the highly anticipated Mongolphobia Mod (which really sounds fun). How to I run the mongolphobia mod?
el_bandito
Legionary
posted 09 November 2008 03:57 EDT (US)     10 / 46       
Not even the starting menu is different?

Michael Jackson
dustinmichaels
Legionary
posted 09 November 2008 19:32 EDT (US)     11 / 46       
There is a menu?
el_bandito
Legionary
posted 09 November 2008 20:49 EDT (US)     12 / 46       
Ok, from what I gather, you might have other mods installed already such as Stainless Steel. Mongolphobia mod sometimes has compatability problems with other mods. If it is not too much of a hassle then please remove all the mods, and then reinstall Mongolphobia. Remember, do not simply swap the folders. You need to dump the files inside and replace some of them.

Michael Jackson
dustinmichaels
Legionary
posted 10 November 2008 02:50 EDT (US)     13 / 46       
Yes! It worked. I can't thank you enough.

[This message has been edited by dustinmichaels (edited 11-10-2008 @ 03:09 AM).]

yesugei
Legionary
posted 18 November 2008 12:00 EDT (US)     14 / 46       
The grand campagin does´nt work for me!! when i start the campagin i just come back to the single player menu!! (i have installed it correctly i think)
el_bandito
Legionary
posted 18 November 2008 20:39 EDT (US)     15 / 46       
You have the same problem as Dustinmichaels I think. Please remove all other mods before installing the Retrofit, Grand unit addon, and my mod.

Michael Jackson
yesugei
Legionary
posted 20 November 2008 08:18 EDT (US)     16 / 46       
I dont have any other mod installed.:s
el_bandito
Legionary
posted 20 November 2008 20:41 EDT (US)     17 / 46       
OK then. I think there is only one solution to the problem. When you install my Mod again, please make sure to take the files from inside the Mod folders and simply dump them into the corresponding folders of your RETROFIT Mod folder. You probably dumped them on your regular M2:TW folder. DO NOT simply swap folders, this is a common mistake, also.

Then start your Retrofit mod and enjoy the changes.

Michael Jackson

[This message has been edited by el_bandito (edited 11-20-2008 @ 09:15 PM).]

yesugei
Legionary
posted 21 November 2008 06:13 EDT (US)     18 / 46       
i have done that several times over and over again!! but still the campagin does´nt work!!
el_bandito
Legionary
posted 24 November 2008 21:56 EDT (US)     19 / 46       
All right. Can you please give me your e-mail address? I will send you my Mod straight from my computer. My e-mail is javadagreat@yahoo.com

Also, if it is no trouble, can you tell me your installation process in full detail? I want to see if all went well.

Michael Jackson
yesugei
Legionary
posted 11 December 2008 14:10 EDT (US)     20 / 46       
my e-mail is: robban_apan@hotmail.com
el_bandito
Legionary
posted 15 December 2008 21:40 EDT (US)     21 / 46       
Ok I sent ya. It should work.

Michael Jackson
Son_of_Ra_62
Legionary
posted 16 December 2008 17:56 EDT (US)     22 / 46       
Hey. I tried to do a battle in mongolphobia but the game exited and a box came up saying "Unspecified error. Medieval II will now exit" Any ideas to resolve this?

Vini, Vidi, Vici-Julias Caesar

Slavery is Freedom
War is Peace
Ignorance is Strength
Quantity and Quality are the same.
el_bandito
Legionary
posted 17 December 2008 00:00 EDT (US)     23 / 46       
Ok, did you just installed the mod, or did this problem surfaced just now?

Do you have any other mods installed before Mongolphobia? Sometimes they do not get along with each other.

Do you have the Kingdoms expansion as well as patch 1.3 atleast?

Michael Jackson
Son_of_Ra_62
Legionary
posted 17 December 2008 17:02 EDT (US)     24 / 46       
The problem surfaced recently. I have SS, Custom Campaign 2,Retrofit MP, and Darth Mod instaled. I believe I have 1.3 installed and I'll check on that.

EDIT: Scratch that. i have 1.5 installed for kingdoms.

Vini, Vidi, Vici-Julias Caesar

Slavery is Freedom
War is Peace
Ignorance is Strength
Quantity and Quality are the same.

[This message has been edited by Son_of_Ra_62 (edited 12-17-2008 @ 05:08 PM).]

el_bandito
Legionary
posted 18 December 2008 23:00 EDT (US)     25 / 46       
Patch 1.5 should be fine with Mongolphobia.

Did you edit any files in the mod? Most of the times that can cause a crash. You mentioned that it crashes before a battle. Was it a custome battle, or a certain battle in a campaign? It is known that tinkering with unit descriptions can cause such crashes.

Michael Jackson

[This message has been edited by el_bandito (edited 12-18-2008 @ 11:03 PM).]

Son_of_Ra_62
Legionary
posted 22 December 2008 17:13 EDT (US)     26 / 46       
It is all battles, custom or otherwise. And i have not tinkered with the files at all. I have reinstalled several times without sucess.

Vini, Vidi, Vici-Julias Caesar

Slavery is Freedom
War is Peace
Ignorance is Strength
Quantity and Quality are the same.
el_bandito
Legionary
posted 22 December 2008 20:56 EDT (US)     27 / 46       
Oh dear, I guess then it is due to the interference with other mods. Well, if you have the time for it, I recommend you to get rid of the other mods(especially SS) first, and then install Mongolphobia. Sorry for the trouble, I really need to make my mod mod-switchable.

Michael Jackson
Son_of_Ra_62
Legionary
posted 23 December 2008 12:42 EDT (US)     28 / 46       
Will I need to reinstall the entire game?

Vini, Vidi, Vici-Julias Caesar

Slavery is Freedom
War is Peace
Ignorance is Strength
Quantity and Quality are the same.
el_bandito
Legionary
posted 23 December 2008 20:47 EDT (US)     29 / 46       
No, complete reinstallation is not necessary. Please make sure you need to reinstall the Retrofit mod and any mods that directly affect the Retrofit mod since Mongolphobia is an extension of Retrofit. BTW, Retrofit for MP came after my mod so that can be the cause, hmmm.

Lets see if Mongolphobia works after that.

Michael Jackson
Son_of_Ra_62
Legionary
posted 30 December 2008 13:36 EDT (US)     30 / 46       
Thanks.

Vini, Vidi, Vici-Julias Caesar

Slavery is Freedom
War is Peace
Ignorance is Strength
Quantity and Quality are the same.
dustinmichaels
Legionary
posted 12 February 2009 18:43 EDT (US)     31 / 46       
At first things were okay, but then when the file was done downloading, a box cam up and said that the folder could not be saved because I can't change the contents in the folder. Am I lacking some sort of program that allow me to open it? I was able to download the earlier versions with no downloading problem.
Andalus
Legionary
posted 12 February 2009 18:52 EDT (US)     32 / 46       
Firstly, there is no need to create multiple threads for one issue, particularly when there is a designated thread like this one. I have closed your two threads for that reason.

It sounds to me like your folder is read only. Right click the files or folders in question, select 'Properties' and ensure 'Read Only' is not ticked.
dustinmichaels
Legionary
posted 13 February 2009 00:59 EDT (US)     33 / 46       
Sorry, I clicked on new topic instead of reply.

And when make it not read me only, it just goes straight back to read me. How can I make it so it stays as non0read me?
el_bandito
Legionary
posted 13 February 2009 01:31 EDT (US)     34 / 46       
Hmm, perhaps you need to turn each files in the folder into non-read only. I had always saved some files as read-only because it never had any problems in the past. Weird. Please try to change every files inside the folder into a non-read-only. Post here again if it doesn't work.

If you run Windows Vista, then that might be the problem. I hate Vista.

Anyway, in the upcoming version v3.1 I will make sure to change every file into a non-read-only.

Michael Jackson
dustinmichaels
Legionary
posted 13 February 2009 05:08 EDT (US)     35 / 46       
Ya it still changes back to read-only. It's weird how it was okay for 2.1. The computer that I am using is not Vista. Darn. Now I can't play version 2.1 or 3. Hahaha now I'm excited for 3.1.
dustinmichaels
Legionary
posted 21 February 2009 20:24 EDT (US)     36 / 46       
Ok I got the read-me only thing under control, but just like when I was installing 2.1, the loading screen says mongolphobia mod, but other than that, there is no difference.Is this because of the custom campaign mod?
dan_monglefobia
Legionary
posted 07 March 2009 17:13 EDT (US)     37 / 46       
well my problem is it says I cant do your mod because its not suported is there any way to stop that or would I have to get a new coumputer.
EnemyofJupitor
HG Alumnus Superbus
posted 08 March 2009 12:07 EDT (US)     38 / 46       
Not supported? Why, what patches/games do you have?

And I shall go Softly into the Night Taking my Dreams As will You
el_bandito
Legionary
posted 08 March 2009 22:15 EDT (US)     39 / 46       
Sorry for the delay.
Ok I got the read-me only thing under control, but just like when I was installing 2.1, the loading screen says mongolphobia mod, but other than that, there is no difference.Is this because of the custom campaign mod?
Yes, I believe so. There are some mods that interfere with Mongolphobia. Custom Campaign Mod could be one. Please uninstall that and then try on Mongolphobia.
well my problem is it says I cant do your mod because its not suported is there any way to stop that or would I have to get a new coumputer.
If you read the README file of my mod you will need M2:TW with the Kingdoms Expansion and patch 1.04 atleast (1.05 is also fine); as well as the Retrofit Mod which you can find here, and the Grand Unit Addon Mod which can be found here. Maybe you haven't installed one of them.

Michael Jackson

[This message has been edited by el_bandito (edited 03-08-2009 @ 10:23 PM).]

dan_monglefobia
Legionary
posted 10 March 2009 03:03 EDT (US)     40 / 46       
I got the two mods and gold addition but whats 1.04 it also wont unzip!

[This message has been edited by dan_monglefobia (edited 03-10-2009 @ 03:12 AM).]

el_bandito
Legionary
posted 10 March 2009 04:23 EDT (US)     41 / 46       
As long as you have the gold edition plus the two mods I mentioned above, it should be alright. Forget about 1.4.

My mod wouldn't unzip you say? Weird, everyone unzipped it without fail before. Well, perhaps you can try some other zip opening programs. Which zip program do you use anyway?

I used 7-Zip to zip the file so perhaps you should use the same? You can download it here. http://www.download.com/7-Zip/3000-2250_4-10045185.html?tag=mncol

Michael Jackson

[This message has been edited by el_bandito (edited 03-10-2009 @ 04:26 AM).]

The Danes
Legionary
posted 05 April 2009 03:28 EDT (US)     42 / 46       
My bug's a little odd...

I played it fine for a while, getting into an Egypt campaign, then a friend came over and I played a hotseat game. Strange thing is, in that hotseat game and since then, all the super factions have been taken out. So I'm playing practically Retrofit with just a super papal state. Fun, but not as fun as Mongolphobia. Also, somehow the Mongols wiped themselves out or something, as I got the message at turn 35-36 as Russia, that they were knocking on Kiev's gate or something, then 4 turns or so later it said they were destroyed. A few rebel 7-star generals and 2 units are all that's there. That might just happen naturally though, I haven't payed attention to Mongols in Vanilla before...

Thanks for any help.

[This message has been edited by The Danes (edited 04-05-2009 @ 03:30 AM).]

maxk
Legionary
posted 16 May 2009 23:01 EDT (US)     43 / 46       
excuse me, but I have a problem with that mod. I downloaded the mongolphobia 3.1, the retrofit 1.0 and the grand unit addon mod v6. When I installed retrofit there was no folder called "unit_models" or "unit_info". I can't install the mod without those folders. Please someone help me.
el_bandito
Legionary
posted 18 May 2009 04:32 EDT (US)     44 / 46       
Unit_models folder should be in the Data folder.

Unit_info folder is in the ui folder, which is in the Data folder.

The data folder should be there once you install GUA after Retrofit. Make sure you installed Grand_Unit_Addon Mod 6.0.

Michael Jackson
hektor10
Legionary
posted 23 November 2009 19:08 EDT (US)     45 / 46       
el_bandito I am having a problem with trying to mod my M2TW. I want the mogolphobias but the problem is I have windows vista. When I download retrofit mod and GUAMv6 I have no problems. However when I try to copy and pste the files that you have on both version 2.1 and 3.1 because I tried both it came up with an error and the mod stopped. The thing is there are 2 seperate sega files. One has the unit files and the other doesn't. They both have text files data files imperial campaign files. So It is very confusing and I am not sure which files to copy and paste to which file. I the 3.1 to work once but it did not allow me to play the grand campaign with the mongols I would pick them press start and it would go back to the campaign menu. Need help thank you, also I am new to modding seems fun. By the way i have the gold pack of mt2w kingdoms.
julvy82
Legionary
posted 24 July 2011 09:31 EDT (US)     46 / 46       
Hey ppl do you mind helping with the insert of the folders you are talking about cause i cant find any of the folders for mongolphobia 3.1 i have been having a hard time looking for them the only thing i had copy is the mongols/timurids mods that i downloaded from here then i read about mongolphobia and i got excited about i will appreciate any help about special just to locate the exact fiels for it thx u.
You must be logged in to post messages.
Please login or register

Hop to:    

Total War Heaven | HeavenGames