You must be logged in to post messages.
Please login or register

Technical Help and Bug Reporting

Hop to:    
Topic Subject: Game stuttering after prolongued use [dual-core]
posted 10 January 2006 10:06 EDT (US)   
I have recently (five days ago) built my first computer. With the following specification.

AMD X2 4200+
XP Professional (32 bit)
1024Kb RAM
~200GB SATA Hard disk space left
Directx 9.0c
XFX Nvidia 7800 GT

The machine booted and worked first time and has not had any serious problems (other than this).

I have upgraded my BIOS, Nforce4 chipset, and graphics card driver (85.98) to the latest releases and have updated RTW to v1.5 (via v1.3) I do not have BI.

The problems started initially after prolongued play. Prior to the RTW updates I experienced some 'crashes to the desktop' which after the patch updates has been replaced with something far stranger.

The first hour of play is always perfect, with very smooth visuals. When I have been playing for 1-2 hours the visuals start to stutter, in both the strategic and tactical environments. It is noticeable in the world map as the small trader caravans skip forward every half second along the roads and the tides follow suit. Within the battelfield rotation of the camera and troop movement and animation skips forward at repeated intervals, of the same nature as those found in the world map.

The only way to remedie this problem is to exit RTW and to reboot the machine (Restarting RTW does not alter things). I am unsure whether a complete crash would occur eventually as the stuttering on the screen is bearable for minutes before I reboot. I have tried running the game at a variety of settings from very high to very low (the setup should handle the highest settings don't you think?) and this doesn't seem to help.

Does this sound like a hardware or software issue? I have ran a free version of 3Dmark05 and recieved a score of 7112. But i'm unsure if this is lower than expected or not?

Any help or suggestions would be much appreciated as this game is so good I dream about it..... sad

posted 10 January 2006 16:29 EDT (US)     1 / 9  
1.3 had a memory leak problem that was "supposed" to be fixed in 1.5. Seems like it isn't.

"The most virtuous are those who content themselves with being virtuous without seeking to appear so."-Plato
posted 10 January 2006 21:00 EDT (US)     2 / 9  
I was just looking into this issue. Reading your symptoms, I guessed you have a Dual-Core cpu. You do. This is a known issue with many programs, and also RTW. It is because of the development tools MS and Intel have provided the developers, like CA. MS estimates that this will not be a problem with most (the vast majority) software released after 2006, since devs will use software that accounts for the load balancing, etc. better.

RTW was developed with tools from MS that were Dual-core unaware. And since RTW pushes certain things that are evidently sensitive to dual core, RTW can attain this behavior exactly as you describe.

The problem with it being a memory leak (and it still could be, or there could ALSO be one, too) is that this is not being seen on single-core CPUs. It is also not being seen on Dual-core with one core turned off.

You should try using only a SINGLE CORE. Others with this problem report it is not an issue anymore when using a single core.,3677,0,365

Either way, post back so we have more data on this issue.

posted 10 January 2006 21:23 EDT (US)     3 / 9  


and graphics card driver (85.98) to

This is really 81.98, right?

And there is also 82.12, but as of yesterday, nVidia had not posted it via the main link yet. But its been tested and found good, esp. with dual-core.

posted 11 January 2006 05:33 EDT (US)     4 / 9  
Hi, Thanks for the prompt response.

After posting the topic I read a thread posted only days earlier that seemed to have the same problem, so sorry for dredging up the same issue. To test the theory I have left the game running in the campaign map (having set the affinity to only one of the CPU cores), whilst I am at work today. This will give it plenty of time to stutter or not. I'm sure this will proove rigorous as I have left the game running perfectly in the past only to return ,after two hours, to be welcomed by the stutter (when both cores were running - prior to this post).

Interestingly, Quake 4 seems to have no problems but Farcry and WH40K DoW is full of graphical glitches and performance problems. So it does seem to be a problem that is addressed with the newer game releases. Is their a diagnostic tool to test for memory leaks?

I will post the outcome when I return to my computer tonight.

For anyone with a similar problem, the following link explains how to assign which core to which program etc..

P.S I did mean 81.98, thanks for the heads up on the new driver

posted 11 January 2006 09:01 EDT (US)     5 / 9  
I just noticed you joined RTWH two days ago. Welcome to Rome Total War Heaven, J_Mann!

And thanks for the feedback. Posts like your are immensely helpful, especially because I don't have a dual core to test with right now.

If you have installed all the AMD drivers, can you post a DXDiag so I can see for reference what OS drivers will show up when properly installed?

It has suddenly occurred to me that everyone may not be properly installing their Dual Core... and that many many not even know how to use a dual core, e.g., how to set affinity for incompatible programs.


posted 12 January 2006 10:36 EDT (US)     6 / 9  

Left idle on the campaign map for eight hours and no crash. Without this site I would never have though of that so, Wartrain in particular, thankyou.

I will have to paste my DXdiag.txt at a later date, perhaps tomorrow. I have been very busy and haven't even managed any gaming. It will be up soon though.

Thanks again

posted 12 January 2006 11:10 EDT (US)     7 / 9  
Thank you in advance for continuing to give input after your problem was solved. That will help out others who lurk, and people considering Dual-core.

I made general dual-core, dual-CPU, and Intel "dual-core" post here a few moments ago. That's the related dual-core thread of another forumer who has also had his porblem solved for the same reason.

posted 14 January 2006 12:18 EDT (US)     8 / 9  
Interesting dual core stuff, my bros comp also has a duel core and his game plays just fine; but I was playing it awhile ago and it did *I think* stutter... but Im not sure if it was really the stutter or just a slow down while windows does what ever.. well ill try the affinity thing... thanks although my comp only has one core Im sure my bro(mike the mighty) will be thankful to ya..
oh and at the top you said your comp had 1024kb of mem(1024KilorBytes) you did mean megabytes of coure right?

[This message has been edited by Matt the Elder (edited 01-14-2006 @ 12:19 PM).]

posted 14 January 2006 18:43 EDT (US)     9 / 9  
Be sure and post back, whether it helps or not. That can be of use for those dual-core users searching for solutions, many of whom simply don't understand the underlying issues with how dual-cores are balanced, and won't believe there can be an issue (and I mean entire software development teams, from my own discussions with some of them off-site ).

At any rate, it is easy for dual-core users to test. Most dual-core users I've seen in real life do not have their machine configured properly in the first place. But even after that, swtiching off one core (affinity) will always resolve any stability issues of dual-core and software, thus allowing troubleshooting without the dual-core question in diagnosis.

He had to mean MB, as the XP core kernal cannot operate in 1024KB. It probably needs about 52MB min, for XP Pro.

Total War Heaven » Forums » Technical Help and Bug Reporting » Game stuttering after prolongued use [dual-core]
You must be logged in to post messages.
Please login or register
Hop to:    
Total War Heaven | HeavenGames